<!DOCTYPE html>
<html lang="en-US" data-bt-theme="Bold News Child 1.0.2">
<head>
<meta property="twitter:card" content="summary"><meta property="og:title" content="Mike Fasano office seeks luggage for foster kids" /><meta property="og:type" content="article" /><meta property="og:url" content="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" /> <meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">
<meta name="mobile-web-app-capable" content="yes">
<meta name="apple-mobile-web-app-capable" content="yes"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<title>Mike Fasano office seeks luggage for foster kids</title>
<meta name="description" content="The luggage will give dignity to kids and families displaced due to emergencies." />
<link rel="canonical" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mike Fasano office seeks luggage for foster kids" />
<meta property="og:description" content="The luggage will give dignity to kids and families displaced due to emergencies." />
<meta property="og:url" content="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" />
<meta property="og:site_name" content="Florida Politics - Campaigns &amp; Elections. Lobbying &amp; Government." />
<meta property="article:publisher" content="https://www.facebook.com/flpolitics" />
<meta property="article:published_time" content="2021-05-19T16:24:45+00:00" />
<meta property="og:image" content="https://floridapolitics.com/wp-content/uploads/2021/05/Luggge-March-2020-scaled.jpg" />
<meta property="og:image:width" content="2560" />
<meta property="og:image:height" content="1440" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@Fla_Pol" />
<meta name="twitter:site" content="@Fla_Pol" />
<meta name="twitter:label1" content="Written by">
<meta name="twitter:data1" content="Staff Reports">
<meta name="twitter:label2" content="Est. reading time">
<meta name="twitter:data2" content="2 minutes">
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://floridapolitics.com/#website","url":"https://floridapolitics.com/","name":"Florida Politics - Campaigns &amp; Elections. Lobbying &amp; Government.","description":"","potentialAction":[{"@type":"SearchAction","target":"https://floridapolitics.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#primaryimage","inLanguage":"en-US","url":"https://floridapolitics.com/wp-content/uploads/2021/05/Luggge-March-2020-scaled.jpg","contentUrl":"https://floridapolitics.com/wp-content/uploads/2021/05/Luggge-March-2020-scaled.jpg","width":2560,"height":1440,"caption":"Greg Giordano of the Pasco County Tax Collector's office poses with donated luggage for foster kids."},{"@type":"WebPage","@id":"https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#webpage","url":"https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/","name":"Mike Fasano office seeks luggage for foster kids","isPartOf":{"@id":"https://floridapolitics.com/#website"},"primaryImageOfPage":{"@id":"https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#primaryimage"},"datePublished":"2021-05-19T16:24:45+00:00","dateModified":"2021-05-19T16:24:45+00:00","author":{"@id":"https://floridapolitics.com/#/schema/person/355ec39469376102838261d81ee75948"},"description":"The luggage will give dignity to kids and families displaced due to emergencies.","breadcrumb":{"@id":"https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/"]}]},{"@type":"BreadcrumbList","@id":"https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://floridapolitics.com/","url":"https://floridapolitics.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#webpage"}}]},{"@type":"Person","@id":"https://floridapolitics.com/#/schema/person/355ec39469376102838261d81ee75948","name":"Staff Reports","image":{"@type":"ImageObject","@id":"https://floridapolitics.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/2945b27f17d04489a276f48156ade98f?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/2945b27f17d04489a276f48156ade98f?s=96&d=mm&r=g","caption":"Staff Reports"},"url":"https://floridapolitics.com/archives/author/staff-reports/"}]}</script>

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Florida Politics - Campaigns &amp; Elections. Lobbying &amp; Government. &raquo; Feed" href="https://floridapolitics.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Politics - Campaigns &amp; Elections. Lobbying &amp; Government. &raquo; Comments Feed" href="https://floridapolitics.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Florida Politics - Campaigns &amp; Elections. Lobbying &amp; Government. &raquo; Mike Fasano office seeks luggage for foster kids Comments Feed" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/floridapolitics.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://floridapolitics.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://floridapolitics.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://floridapolitics.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='post-views-counter-frontend-css' href='https://floridapolitics.com/wp-content/plugins/post-views-counter/css/frontend.css?ver=1.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='video_popup_close_icon-css' href='https://floridapolitics.com/wp-content/plugins/video-popup/css/vp-close-icon/close-button-icon.css?ver=1621446735' type='text/css' media='all' />
<link rel='stylesheet' id='oba_youtubepopup_css-css' href='https://floridapolitics.com/wp-content/plugins/video-popup/css/YouTubePopUp.css?ver=1621446735' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css' href='https://floridapolitics.com/wp-content/themes/bold-news/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css' href='https://floridapolitics.com/wp-content/themes/bold-news-child/style.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='bold-news-style-css' href='https://floridapolitics.com/wp-content/themes/bold-news/style.css?ver=5.7.2' type='text/css' media='screen' />
<style id='bold-news-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='bold-news-print-css' href='https://floridapolitics.com/wp-content/themes/bold-news/print.css?ver=5.7.2' type='text/css' media='print' />
<link rel='stylesheet' id='bold-news-magnific-popup-css' href='https://floridapolitics.com/wp-content/themes/bold-news/magnific-popup.css?ver=5.7.2' type='text/css' media='screen' />
<link rel='stylesheet' id='bold-news-fonts-css' href='https://fonts.googleapis.com/css?family=Roboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100italic%2C200italic%2C300italic%2C400italic%2C500italic%2C600italic%2C700italic%2C800italic%2C900italic%7CRoboto+Slab%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100italic%2C200italic%2C300italic%2C400italic%2C500italic%2C600italic%2C700italic%2C800italic%2C900italic%7CRoboto+Slab%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100italic%2C200italic%2C300italic%2C400italic%2C500italic%2C600italic%2C700italic%2C800italic%2C900italic%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100italic%2C200italic%2C300italic%2C400italic%2C500italic%2C600italic%2C700italic%2C800italic%2C900italic%7CRoboto+Condensed%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%2C100italic%2C200italic%2C300italic%2C400italic%2C500italic%2C600italic%2C700italic%2C800italic%2C900italic&#038;subset=latin%2Clatin-ext&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='boldthemes_css-css' href='https://floridapolitics.com/wp-content/themes/bold-news/framework/css/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css' href='https://floridapolitics.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://floridapolitics.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.7' type='text/css' media='all' />
<script>var jquery_placeholder_url = 'https://floridapolitics.com/wp-content/plugins/gravity-forms-placeholders/jquery.placeholder-1.0.1.js';</script><script type='text/javascript' src='https://floridapolitics.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/bold-news/bt_elements.js?ver=5.7.2' id='bt_plugin_enqueue-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/bold-page-builder/script_fe.js?ver=3.1.2' id='bt_bb_fe-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/bt_cost_calculator/jquery.dd.js?ver=5.7.2' id='bt_cc_dd-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/bt_cost_calculator/cc.main.js?ver=5.7.2' id='bt_cc_main-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/video-popup/js/YouTubePopUp.jquery.js?ver=1621446735' id='oba_youtubepopup_plugin-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/video-popup/js/YouTubePopUp.js?ver=1621446735' id='oba_youtubepopup_activate-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/html5shiv.min.js?ver=1' id='html5shiv-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/respond.min.js?ver=1' id='respond-js'></script>
<script type='text/javascript' id='bold-news-header-misc-js-before'>
window.BoldThemesURI = "https://floridapolitics.com/wp-content/themes/bold-news"; window.BoldThemesAJAXURL = "https://floridapolitics.com/wp-admin/admin-ajax.php";window.boldthemes_text = [];window.boldthemes_text.previous = 'previous';window.boldthemes_text.next = 'next';
</script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/header.misc.js?ver=5.7.2' id='bold-news-header-misc-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/gravity-forms-placeholders/gf.placeholders.js?ver=1.0' id='_gf_placeholders-js'></script>
<link rel="https://api.w.org/" href="https://floridapolitics.com/wp-json/" /><link rel="alternate" type="application/json" href="https://floridapolitics.com/wp-json/wp/v2/posts/430647" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://floridapolitics.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://floridapolitics.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://wp.me/pcPG06-1O1V' />
<link rel="alternate" type="application/json+oembed" href="https://floridapolitics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffloridapolitics.com%2Farchives%2F430647-mike-fasano-office-seeks-luggage-for-foster-kids%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://floridapolitics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ffloridapolitics.com%2Farchives%2F430647-mike-fasano-office-seeks-luggage-for-foster-kids%2F&#038;format=xml" />

<script async src="https://www.googletagmanager.com/gtag/js?id=G-1SC02PT8P8"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-1SC02PT8P8');
</script> <script type='text/javascript'>
			var video_popup_unprm_general_settings = {
    			'unprm_r_border': ''
			};
		</script>
<style type='text/css'>img#wpstats{display:none}</style>
<style type="text/css">
				#wp-admin-bar-pvc-post-views .pvc-graph-container { padding-top: 6px; padding-bottom: 6px; position: relative; display: block; height: 100%; box-sizing: border-box; }
				#wp-admin-bar-pvc-post-views .pvc-line-graph {
					display: inline-block;
					width: 1px;
					margin-right: 1px;
					background-color: #ccc;
					vertical-align: baseline;
				}
				#wp-admin-bar-pvc-post-views .pvc-line-graph:hover { background-color: #eee; }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-0 { height: 1% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-1 { height: 5% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-2 { height: 10% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-3 { height: 15% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-4 { height: 20% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-5 { height: 25% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-6 { height: 30% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-7 { height: 35% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-8 { height: 40% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-9 { height: 45% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-10 { height: 50% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-11 { height: 55% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-12 { height: 60% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-13 { height: 65% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-14 { height: 70% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-15 { height: 75% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-16 { height: 80% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-17 { height: 85% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-18 { height: 90% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-19 { height: 95% }
				#wp-admin-bar-pvc-post-views .pvc-line-graph-20 { height: 100% }
			</style><link rel="icon" href="https://floridapolitics.com/wp-content/uploads/2021/05/fpfavicon.png" sizes="32x32" />
<link rel="icon" href="https://floridapolitics.com/wp-content/uploads/2021/05/fpfavicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://floridapolitics.com/wp-content/uploads/2021/05/fpfavicon.png" />
<meta name="msapplication-TileImage" content="https://floridapolitics.com/wp-content/uploads/2021/05/fpfavicon.png" />
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-430647 single-format-standard bt_bb_plugin_active bt_bb_fe_preview_toggle bodyPreloader btMenuLeftEnabled btMenuBelowLogo btStickyEnabled btStandardHeadline btContentOverHeadline btLightSkin btNoDashInSidebar btTopToolsInMenuArea btRemovePreloader btSoftRoundedButtons btWithSidebar btSidebarRight aa-prefix-flori-" data-autoplay="0">
<div class="btPageWrap" id="top">
<header class="mainHeader btClear gutter ">
<div class="port">
<div class="topBar btClear">
<div class="topBarPort btClear">
<div class="topTools btTopToolsLeft btTextLeft">
<span id="time60a5504ff156f" class="btIconWidget btDateWidget"><span class="btIconWidgetIcon"><span class="btIco btIcoDefaultType btIcoAccentColor"><span data-ico-fa="&#xf073;" class="btIcoHolder"></span></span></span><span class="btIconWidgetContent">
<span class="btIconWidgetTitle">May 19, 2021</span>
</span>
</span> </div>
<div class="topTools btTopToolsRight btTextRight">
<a href="https://floridapolitics.com/podcasts/" target="_self" class="btIconWidget btAccentIconWidget btWidgetWithText"><span class="btIconWidgetIcon"><span class="btIco btIcoDefaultType btIcoDefaultColor"><span data-ico-fa="&#xf2ce;" class="btIcoHolder"></span></span></span><span class="btIconWidgetContent"><span class="btIconWidgetText">Podcasts</span></span></a><a href="http://influencemagazineflorida.com/" target="_self" class="btIconWidget btAccentIconWidget btWidgetWithText"><span class="btIconWidgetIcon"><span class="btIco btIcoDefaultType btIcoDefaultColor"><span data-ico-fa="&#xf02d;" class="btIcoHolder"></span></span></span><span class="btIconWidgetContent"><span class="btIconWidgetText">Influence Magazine</span></span></a> </div>
</div>
</div>
<div class="btLogoArea menuHolder btClear">
<span class="btVerticalMenuTrigger">&nbsp;<span class="btIco btIcoDefaultType"><a href="#" target="_self" data-ico-fa="&#xf0c9;" class="btIcoHolder"></a></span></span>
<span class="btHorizontalMenuTrigger">&nbsp;<span class="btIco btIcoDefaultType"><a href="#" target="_self" data-ico-fa="&#xf0c9;" class="btIcoHolder"></a></span></span>
<div class="logo">
<span>
<a href="https://floridapolitics.com/"><img class="btMainLogo" data-hw="2.9561403508772" src="https://floridapolitics.com/wp-content/uploads/2015/04/fpwebsitelogo.fw_2.png" alt="Florida Politics - Campaigns &amp; Elections. Lobbying &amp; Government."></a> </span>
</div>
<div class="topBarInLogoArea">
<div class="topBarInLogoAreaCell">
<div class="btTopBox widget_text"> <div class="textwidget"><div><div class="dfad dfad_pos_1 dfad_first" id="_ad_419420"><a href="https://coastalcloud.us/"><img src="https://floridapolitics.com/wp-content/uploads/2021/04/Coastal-Cloud-Digital-Ads-March-2021-970x90-partner.jpg" alt="" width="970" height="90" class="alignnone size-full wp-image-429726" /></a></div></div>
</div>
</div> </div>
</div>
</div><div class="btBelowLogoArea btClear"> <div class="menuPort">
<div class="logoBelowInline">
<span>
<a href="https://floridapolitics.com/"><img class="btMainLogo" data-hw="2.9561403508772" src="https://floridapolitics.com/wp-content/uploads/2015/04/fpwebsitelogo.fw_2.png" alt="Florida Politics - Campaigns &amp; Elections. Lobbying &amp; Government."></a>
</span>
</div>
<div class="topBarInMenu">
<div class="topBarInMenuCell">
<a href="https://www.facebook.com/flpolitics" target="_self" class="btIconWidget btAccentIconWidget"><span class="btIconWidgetIcon"><span class="btIco btIcoDefaultType btIcoDefaultColor"><span data-ico-fa="&#xf09a;" class="btIcoHolder"></span></span></span></a><a href="https://twitter.com/Fla_Pol" target="_self" class="btIconWidget btAccentIconWidget"><span class="btIconWidgetIcon"><span class="btIco btIcoDefaultType btIcoDefaultColor"><span data-ico-fa="&#xf099;" class="btIcoHolder"></span></span></span></a><a href="https://www.instagram.com/fla_pol" target="_self" class="btIconWidget btAccentIconWidget"><span class="btIconWidgetIcon"><span class="btIco btIcoDefaultType btIcoDefaultColor"><span data-ico-fa="&#xf16d;" class="btIcoHolder"></span></span></span></a><div class="btTopBox widget_search"><div class="btSearch"><span class="btIco btIcoDefaultType btIcoDefaultColor"><a href="#" target="_self" data-ico-fa="&#xf002;" class="btIcoHolder"></a></span>
<div class="btSearchInner gutter" role="search">
<div class="btSearchInnerContent port">
<form action="https://floridapolitics.com/" method="get"><input type="text" name="s" placeholder="Looking for..." class="untouched">
<button type="submit" data-icon="&#xf105;"></button>
</form>
<div class="btSearchInnerClose"><span class="btIco "><a href="#" target="_self" data-ico-fa="&#xf00d;" class="btIcoHolder"></a></span></div>
</div>
</div></div></div> </div>
</div>
<nav>
<ul id="menu-main-menu" class="menu"><li id="menu-item-1259" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1259"><a href="https://floridapolitics.com/">Home</a></li><li id="menu-item-392321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392321"><a href="https://floridapolitics.com/archives/category/presidential/">Presidential</a></li><li id="menu-item-427709" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-427709"><a href="https://floridapolitics.com/archives/category/coronavirus/">Coronavirus</a><ul class="sub-menu"><li id="menu-item-427708" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-427708"><a href="https://floridapolitics.com/archives/category/corona-economics/">Corona Economics</a></li></ul></li><li id="menu-item-1687" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1687"><a href="https://floridapolitics.com/archives/category/influence/">Legislative</a></li><li id="menu-item-1667" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1667"><a href="https://floridapolitics.com/archives/category/local/">Communities</a><ul class="sub-menu"><li id="menu-item-220504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220504"><a href="https://floridapolitics.com/archives/category/jax/">Jax</a></li><li id="menu-item-220505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-220505"><a href="https://floridapolitics.com/archives/category/orlando/">Orlando</a></li><li id="menu-item-316551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-316551"><a href="https://floridapolitics.com/archives/category/panhandle/">Panhandle</a></li><li id="menu-item-283046" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-283046"><a href="https://floridapolitics.com/archives/category/south-florida/">South Florida</a></li><li id="menu-item-283047" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-283047"><a href="https://floridapolitics.com/archives/category/sw-florida/">SW Florida</a></li><li id="menu-item-220506" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-220506"><a href="https://floridapolitics.com/archives/category/tampabay/">Tampa Bay</a></li></ul></li><li id="menu-item-283048" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-283048"><a href="https://floridapolitics.com/archives/category/federal/">Federal</a></li><li id="menu-item-306516" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-306516"><a href="https://floridapolitics.com/archives/category/2022/">2022</a></li><li id="menu-item-392318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392318"><a href="https://floridapolitics.com/archives/category/emails-opinions/">Emails &amp; Opinions</a></li>
</ul>
</nav>
</div>
</div>
</div>
</header>
<div class="btContentWrap btClear">
<section class="boldSection bottomSemiSpaced btPageHeadline gutter  topSemiSpaced wBackground cover btParallax btDarkSkin btBackgroundOverlay btSolidDarkBackground " style="background-image:url(https://floridapolitics.com/wp-content/uploads/2021/05/Luggge-March-2020-scaled.jpg)" data-parallax="0.8" data-parallax-offset="-250"><div class="port"><header class="header btClear extralarge"><div class="btSuperTitle"><span><div class="btBreadCrumbs"><nav><ul><span class="btArticleCategories"><a href="https://floridapolitics.com/archives/category/tampabay/" class="btArticleCategory cat-item-31260">Tampa Bay</a></span></ul></nav></div></span></div><div class="dash"><h1><span class="headline">Mike Fasano office seeks luggage for foster kids<div class='headline_feat_image_caption'>Greg Giordano of the Pasco County Tax Collector's office poses with donated luggage for foster kids. </div></span></h1></div></header></div></section> <div class="btBlogHeaderContent">
<section id="bt_section60a5505001f5a" class="boldSection gutter boxed inherit"><div class="port"><div class="boldCell"><div class="boldCellInner"><div class="boldRow "><div class="boldRowInner"></div></div></div></div></div></section> </div> <div class="btContentHolder">
<div class="btContent">
<article class="boldSection btArticle gutter divider btArticleWithSideInfo post-430647 post type-post status-publish format-standard has-post-thumbnail hentry category-tampabay tag-foster-care tag-luggage-of-love tag-mike-fasano tag-pasco-county btPostSingleItemStandard"><div class="port"><div class="boldCell"><div class="boldRow"><div class="rowItem col-sm-12 btTextLeft"><div class="btArticleContentWrap"><div class="btArticleSideinfo"><div class="btArticleSideMeta"><header class="header btClear medium"><div class="dash"></div><div class="btSubTitle"><a href="https://floridapolitics.com/archives/author/staff-reports/" class="btArticleAuthor"> <img alt='' src='https://secure.gravatar.com/avatar/2945b27f17d04489a276f48156ade98f?s=144&#038;d=mm&#038;r=g' class='avatar avatar-144 photo' height='144' width='144' loading='lazy' />Staff Reports</a><span class="btArticleDate">May 19, 2021</span><span class="btArticleReadingTime">4<span>min</span></span><a href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#comments" class="btArticleComments">0</a></div></header><span class="btIco btIcoFilledType btIcoSmallSize btIcoFacebook"><a href="https://www.facebook.com/sharer/sharer.php?u=https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" target="_self" data-ico-fa="&#xf09a;" class="btIcoHolder"></a></span><span class="btIco btIcoFilledType btIcoSmallSize btIcoTwitter"><a href="https://twitter.com/intent/tweet?text=https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" target="_self" data-ico-fa="&#xf099;" class="btIcoHolder"></a></span><span class="btIco btIcoFilledType btIcoSmallSize btIcoLinkedin"><a href="https://www.linkedin.com/shareArticle?url=https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" target="_self" data-ico-fa="&#xf0e1;" class="btIcoHolder"></a></span><span class="btIco btIcoFilledType btIcoSmallSize btIcoVK"><a href="https://vkontakte.ru/share.php?url=https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" target="_self" data-ico-fa="&#xf189;" class="btIcoHolder"></a></span><span class="btIco btIcoFilledType btIcoSmallSize btIcoWhatsApp"><a href="https://api.whatsapp.com/send?text=https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" target="_self" data-ico-fa="&#xf232;" class="btIcoHolder"></a></span><div class="btTags"><ul><li><a href="https://floridapolitics.com/archives/tag/foster-care/">foster care</a></li><li><a href="https://floridapolitics.com/archives/tag/luggage-of-love/">Luggage of Love</a></li><li><a href="https://floridapolitics.com/archives/tag/mike-fasano/">Mike Fasano</a></li><li><a href="https://floridapolitics.com/archives/tag/pasco-county/">Pasco County</a></li></ul></div></div></div><div class="btArticleContent"><div class="btRegularMediaPosition"><div class="btMediaBox btCarouselSmallNav"><div class="boldPhotoSlide "><div class="bpbItem"><img src="https://floridapolitics.com/wp-content/uploads/2021/05/Luggge-March-2020-1280x720.jpg" alt="Luggage of Love"></div></div></div></div><div class="btArticleExcerpt">The luggage will give dignity to kids and families displaced due to emergencies. </div><div class="btArticleBody portfolioBody btTextLeft"><div class="bt_bb_wrapper"><p class="p1" style="text-align: justify;">Pasco County Tax Collector <strong>Mike</strong> <strong>Fasano</strong> and his office are collecting gently used or new suitcases for foster children and victims of domestic abuse.</p>
<p class="p1" style="text-align: justify;">Fasano and his staff collect the suitcases throughout the year, which also includes other travel-related bags, to provide dignity to displaced children and families who are often shuffled from one place to another with only plastic bags to carry their belongings.</p>
<p class="p1" style="text-align: justify;">The effort is part of the <strong><a href="https://www.pascocountyfl.net/3580/Luggage-of-Love-Program">Luggage of Love</a></strong> program coordinated in Pasco County by the University of Florida’s Pasco Extension office.</p>
<p class="p1" style="text-align: justify;">“It is heartbreaking to think that a child or a mother in distress may only have plastic garbage bags which they must use to carry their belongings,” Fasano said in a statement. “I am so proud of both our staff and members of the community who have supported this program over the past few years.</p>
<p class="p1" style="text-align: justify;">“Donations of everything from suitcases to duffle bags and backpacks are the lifeblood of this charity.  If you have not given before and have some unused luggage you could donate, please reach out to our office.  We will work with you in any way that we can to help get the luggage into the hands of those most in need.”</p><div class="flori-content" style="margin-left: auto; margin-right: auto; text-align: center; " id="flori-118902707"><div id="post-ads"><div class="dfad dfad_pos_1 dfad_first" id="post-ads_ad_387613"><a href="http://www.shutts.com/"><img loading="lazy" src="https://floridapolitics.com/wp-content/uploads/2020/12/Digital-Ad_728x90.jpg" alt="" width="718" height="90" class="alignnone size-full wp-image-387614" /></a></div></div></div>
<p class="p1" style="text-align: justify;">The program serves foster children removed from their homes due to emergency situations and single mothers escaping domestic violence.</p>
<p class="p1" style="text-align: justify;">While Fasano’s office collects luggage throughout the year for the program, donations are currently running low, creating a need for an extra boost in the community.</p>
<p class="p1" style="text-align: justify;">“Thank you so very much for the donations we have received in the past,” said <b>Elizabeth Urquiola, </b>program coordinator for the UF Pasco Extension Office &amp; the Luggage of Love program.  “We can’t thank our community enough for the amazing generosity. We need to keep our closets full because children and mothers may be in need at any time.</p>
<p class="p1" style="text-align: justify;">“Please help spread the love to our displaced children in Pasco County through our Luggage of Love program. Your donations will always be put to good use.”</p>
<p class="p1" style="text-align: justify;">Those interested in donating or learning more about the program can contact Assistant Tax Collector <strong>Greg</strong> <strong>Giordano</strong> at 727-847-8179 or Urquiola at 352-521-1254, ext. 5325.</p><div class="flori-content_2" style="margin-left: auto; margin-right: auto; text-align: center; " id="flori-375760540"><div id="post-ads"><div class="dfad dfad_pos_1 dfad_first" id="post-ads_ad_412491"><a href="https://goto.effectv.com/SE_FL_ONAD_21Q103_2021-Elections_FloridaPoliticscom-LP.html"><img loading="lazy" class="alignnone size-full wp-image-412492" src="https://floridapolitics.com/wp-content/uploads/2021/03/Political2021_728x90_A.jpg" alt="" width="728" height="90" /></a></div></div></div>
<p class="p1" style="text-align: justify;">Donations can be dropped off at any of the five tax collector offices in the county.  Please visit <strong><a href="http://www.pascotaxes.com/"><span class="s1">www.pascotaxes.com</span></a></strong> for tax office locations and hours of operation.</p>
<div class="post-views post-430647 entry-meta">
<span class="post-views-icon dashicons dashicons-chart-bar"></span>
<span class="post-views-label">Post Views: </span>
<span class="post-views-count">123</span>
</div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-430647" class="share-facebook sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-430647" class="share-twitter sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div></div></div></div></div></div></div></div></div></article>
<section class="boldSection gutter bottomMediumSpaced btAboutAutorSection">
<div class="port">
<div class="boldRow">
<div class="rowItem col-sm-12 btAboutAutor">
<div class="btAboutAuthor"><div class="aaAvatar"><img alt='' src='https://secure.gravatar.com/avatar/2945b27f17d04489a276f48156ade98f?s=280&#038;d=mm&#038;r=g' class='avatar avatar-280 photo' height='140' width='140' loading='lazy' /></div><div class="aaTxt"><h4>Staff Reports</h4>
<p></p>
<div class="btClear btSeparator bottomExtraSmallSpaced noBorder"><hr></div>
<div class="aaSocial">
<a href="https://floridapolitics.com/archives/author/staff-reports/" class="btBtn btBtn btnFilledStyle btnAlternateColor btnSmall btnNormalWidth btnLeftPosition btnNoIcon"><span class="btnInnerText">VIEW ALL POSTS</span></a>
</div>
</div>
</div> </div>
</div>
</div>
</section>
<section class="boldSection gutter bottomSemiSpaced"><div class="port"><div class="boldRow btNextPrevRow neighboringArticles bottomSmallSpaced"><div class="rowItem col-xs-12 col-sm-12 col-md-6 btTextLeft"><h4 class="nbs nsPrev"><a href="https://floridapolitics.com/archives/430631-jacksonville-mayoral-candidate-matt-carlucci-parts-ways-with-political-consultants/"><span class="nbsImage"><span class="nbsImgHolder" style="background-image:url('https://floridapolitics.com/wp-content/uploads/2021/05/Matt-Carlucci_1-160x160.jpg');"></span></span><span class="nbsItem"><span class="nbsDir">previous</span><span class="nbsTitle">Jacksonville mayoral candidate Matt Carlucci parts ways with political consultants</span></span></a></h4></div><div class="rowItem col-xs-12 col-sm-12 col-md-6 btTextRight"><h4 class="nbs nsNext"><a href="https://floridapolitics.com/archives/430616-as-val-demings-looks-at-senate-run-aramis-ayala-eyes-her-congressional-seat/"><span class="nbsItem"><span class="nbsDir">next</span><span class="nbsTitle">As Val Demings looks at Senate run, Aramis Ayala eyes her congressional seat</span></span><span class="nbsImage"><span class="nbsImgHolder" style="background-image:url('https://floridapolitics.com/wp-content/uploads/2021/05/Demings-Ayala-5.19.21-160x160.jpg');"></span></span></a></h4></div></div><div class="boldRow"><div class="rowItem col-sm-12 btTextLeft">
<div id="comments" class="btCommentsBox">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://floridapolitics.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published. Required fields are marked *</p><div class="pcItem btComment"><label for="comment">Comment <span class="required">*</span></label><p><textarea id="comment" name="comment" cols="30" rows="8" aria-required="true"></textarea></p></div><div class="row"><div class="pcItem"><label for="author">Name <span class="required">*</span></label>
<p><input id="author" name="author" type="text" value="" aria-required='true' /></p></div>
<div class="pcItem"><label for="email">Email <span class="required">*</span></label>
<p><input id="email" name="email" type="text" value="" aria-required='true' /></p></div>
<div class="pcItem"><label for="url">Website</label><p><input id="url" name="url" type="text" value="" /></p></div>
</div><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><button type="submit" value="Post Comment" id="btSubmit" class="btBtn btnFilledStyle btnRightPosition btnSmall btnAccent btnAccentColor btnIco" name="submit"><span class="btnInnerText">Post Comment</span><span class="btIco "><span data-ico-fa="&#xf1d8;" class="btIcoHolder"></span></span></button> <input type='hidden' name='comment_post_ID' value='430647' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="7073b6076b" /></p><input type="hidden" id="ak_js" name="ak_js" value="102" /><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form> </div>
<p class="akismet_comment_form_privacy_notice">This site uses Akismet to reduce spam. <a href="https://akismet.com/privacy/" target="_blank" rel="nofollow noopener">Learn how your comment data is processed</a>.</p>
</div></div></div></div></section> </div>
<aside class="btSidebar btTextLeft"><div class="btBox widget_text"> <div class="textwidget"><div><div class="dfad dfad_pos_1 dfad_first" id="_ad_427720"><a href="https://www.securingourfuture.com/florida-insurance/"><img class="alignnone size-full wp-image-427721" src="https://floridapolitics.com/wp-content/uploads/2021/05/SOF_banner_ads_Florida_Cost_300x500.png" alt="" width="300" height="500" /></a></div></div>
</div>
</div>
<div class="btBox widget_recent_entries">
<h4><span>Recent Posts</span></h4>
<ul>
<li>
<a href="https://floridapolitics.com/archives/430665-majority-of-florida-college-football-teams-plan-for-full-capacity-this-fall/">Majority of Florida college football teams plan for full capacity this fall</a>
</li>
<li>
<a href="https://floridapolitics.com/archives/430643-fried-gubernatorial-run-makes-sense/">Nikki Fried says weighing gubernatorial run &#8216;makes sense,&#8217; but holds off on official announcement</a>
</li>
<li>
<a href="https://floridapolitics.com/archives/430671-state-gaming-commission-proposal-headed-to-governors-desk/">State gaming commission proposal headed to Governor&#8217;s desk</a>
</li>
<li>
<a href="https://floridapolitics.com/archives/430661-people-are-going-to-sue-gaming-compact-passes-house-lawsuits-expected/">‘People are going to sue’: Gaming compact passes House, lawsuits expected</a>
</li>
<li>
<a href="https://floridapolitics.com/archives/430649-ballard-partners-to-help-freedom-for-all-americans-with-equality-act-push/">Ballard Partners to help Freedom for All Americans with Equality Act push</a>
</li>
</ul>
</div><div class="btBox widget_categories"><h4><span>Categories</span></h4>
<ul>
<li class="cat-item cat-item-67326"><a href="https://floridapolitics.com/archives/category/2022/">2022</a>
</li>
<li class="cat-item cat-item-76061"><a href="https://floridapolitics.com/archives/category/america-in-crisis/">America in Crisis</a>
</li>
<li class="cat-item cat-item-47159"><a href="https://floridapolitics.com/archives/category/apolitical/">APolitical</a>
</li>
<li class="cat-item cat-item-73115"><a href="https://floridapolitics.com/archives/category/corona-economics/">Corona Economics</a>
</li>
<li class="cat-item cat-item-72116"><a href="https://floridapolitics.com/archives/category/coronavirus/">Coronavirus</a>
</li>
<li class="cat-item cat-item-58632"><a href="https://floridapolitics.com/archives/category/emails-opinions/">Emails &amp; Opinions</a>
</li>
<li class="cat-item cat-item-82684"><a href="https://floridapolitics.com/archives/category/epilogue-trump/">Epilogue-Trump</a>
</li>
<li class="cat-item cat-item-47158"><a href="https://floridapolitics.com/archives/category/federal/">Federal</a>
</li>
<li class="cat-item cat-item-86659"><a href="https://floridapolitics.com/archives/category/gaetzgate/">Gaetzgate</a>
</li>
<li class="cat-item cat-item-160"><a href="https://floridapolitics.com/archives/category/headlines/">Headlines</a>
</li>
<li class="cat-item cat-item-64"><a href="https://floridapolitics.com/archives/category/influence/">Influence</a>
</li>
<li class="cat-item cat-item-31258"><a href="https://floridapolitics.com/archives/category/jax/">Jax</a>
</li>
<li class="cat-item cat-item-161"><a href="https://floridapolitics.com/archives/category/local/">Local</a>
</li>
<li class="cat-item cat-item-31259"><a href="https://floridapolitics.com/archives/category/orlando/">Orlando</a>
</li>
<li class="cat-item cat-item-70700"><a href="https://floridapolitics.com/archives/category/panhandle/">Panhandle</a>
</li>
<li class="cat-item cat-item-75679"><a href="https://floridapolitics.com/archives/category/presidential/">Presidential</a>
</li>
<li class="cat-item cat-item-74567"><a href="https://floridapolitics.com/archives/category/re-open-florida/">Re-Open Florida</a>
</li>
<li class="cat-item cat-item-47160"><a href="https://floridapolitics.com/archives/category/south-florida/">South Florida</a>
</li>
<li class="cat-item cat-item-67063"><a href="https://floridapolitics.com/archives/category/special-reports/">Special Reports</a>
</li>
<li class="cat-item cat-item-87105"><a href="https://floridapolitics.com/archives/category/special-session/">Special Session</a>
</li>
<li class="cat-item cat-item-58626"><a href="https://floridapolitics.com/archives/category/sw-florida/">SW Florida</a>
</li>
<li class="cat-item cat-item-58786"><a href="https://floridapolitics.com/archives/category/tallahassee/">Tallahassee</a>
</li>
<li class="cat-item cat-item-31260"><a href="https://floridapolitics.com/archives/category/tampabay/">Tampa Bay</a>
</li>
<li class="cat-item cat-item-69940"><a href="https://floridapolitics.com/archives/category/tech/">Tech</a>
</li>
<li class="cat-item cat-item-1"><a href="https://floridapolitics.com/archives/category/uncategorized/">Uncategorized</a>
</li>
<li class="cat-item cat-item-82116"><a href="https://floridapolitics.com/archives/category/vaccine/">Vaccine</a>
</li>
</ul>
</div></aside>
</div>
</div>
<div class="bt_bb_wrapper"><section id="bt_section60a550500d768" class="boldSection topMediumSpaced bottomMediumSpaced btDarkSkin gutter boxed inherit" style="background-color:#181818  !important;"><div class="port"><div class="boldCell"><div class="boldCellInner"><div class="boldRow "><div class="boldRowInner"><div class="rowItem col-md-6 col-sm-12 btTextLeft inherit btFooterText" data-width="6"><div class="rowItemContent"><div class="btClear btSeparator topMediumSpaced noBorder"><hr></div><span class="btIco btIcoDefaultType btIcoMediumSize btIcoDefaultColor btIconCircleShape btFooterLargeTitle .icon-color" style="color: #ffffff !important;"><span data-ico-es="&#xea5f;" class="btIcoHolder"><span>#FlaPol</span></span></span><div class="btClear btSeparator topSmallSpaced bottomSmallSpaced border"><hr></div><div class="btText"><p style="text-align: justify;">Florida Politics is a statewide, new media platform covering campaigns, elections, government, policy, and lobbying in Florida. This platform and all of its content are owned by Extensive Enterprises Media.</p>
<p>Publisher: Peter Schorsch</p>
<p style="text-align: justify;">Contributors &amp; reporters: Phil Ammann, Jason Delgado, Drew Dixon, Renzo Downey, Rick Flagg, A.G. Gancarski, Joe Henderson, Janelle Irwin, Ryan Nicol, Jacob Ogles, Scott Powers, Andrew Wilson, and Kelly Hayes.</p>
<p>Email: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="61310415041321270d0e13080500310e0d08150802124f020e0c">[email&#160;protected]</a><br />
Phone: (727) 642-3162<br />
Address: 204 37th Avenue North #182<br />
St. Petersburg, Florida 33704</p>
</div><div class="btClear btSeparator topMediumSpaced noBorder"><hr></div><span class="btIco btIcoFilledType btIcoMediumSize btIcoDefaultColor btIconCircleShape"><a href="https://www.facebook.com/flpolitics/" target="no_target" data-ico-fa="&#xf09a;" class="btIcoHolder"></a></span><span class="btIco btIcoFilledType btIcoMediumSize btIcoDefaultColor btIconCircleShape"><a href="https://twitter.com/Fla_Pol" target="no_target" data-ico-fa="&#xf099;" class="btIcoHolder"></a></span><div class="btClear btSeparator topMediumSpaced noBorder"><hr></div></div></div><div class="rowItem col-md-6 col-sm-12 btTextLeft inherit" data-width="6"><div class="rowItemContent"><div class="btClear btSeparator topMediumSpaced noBorder"><hr></div><span class="btIco btIcoDefaultType btIcoMediumSize btIcoDefaultColor btIconCircleShape btFooterLargeTitle" style="color: #ffffff !important;"><span data-ico-s7="&#xe62e;" class="btIcoHolder"><span>Sign up for Sunburn</span></span></span><div class="btClear btSeparator topSmallSpaced bottomSmallSpaced border"><hr></div><div class="btText"><div role="form" class="wpcf7" id="wpcf7-f2056-o1" lang="en-US" dir="ltr">
<div class="screen-reader-response"><p role="status" aria-live="polite" aria-atomic="true"></p> <ul></ul></div>
<form action="/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#wpcf7-f2056-o1" method="post" class="wpcf7-form init" novalidate="novalidate" data-status="init">
<div style="display: none;">
<input type="hidden" name="_wpcf7" value="2056" />
<input type="hidden" name="_wpcf7_version" value="5.4.1" />
<input type="hidden" name="_wpcf7_locale" value="en_US" />
<input type="hidden" name="_wpcf7_unit_tag" value="wpcf7-f2056-o1" />
<input type="hidden" name="_wpcf7_container_post" value="0" />
<input type="hidden" name="_wpcf7_posted_data_hash" value="" />
</div>
<div class="boldRow btBookingRow btFormRowActive" style="z-index: 10; margin: 0;">
<div class="rowItem col-sm-12 col-lg-8 btLightSkin" style="margin-bottom: 10px; padding: 0 4px 0 0;"><span class="wpcf7-form-control-wrap your-email"><input type="email" name="your-email" value="" size="40" class="wpcf7-form-control wpcf7-text wpcf7-email wpcf7-validates-as-required wpcf7-validates-as-email" aria-required="true" aria-invalid="false" placeholder="Enter your email address" /></span></div>
<div class="rowItem col-sm-12 col-lg-4 btNoPadding style=" padding: 0;"><input type="submit" value="Subscribe" class="wpcf7-form-control wpcf7-submit" /></div>
</div>
<div class="wpcf7-response-output" aria-hidden="true"></div></form></div></div><div class="btClear btSeparator topSmallSpaced bottomSmallSpaced noBorder"><hr></div><span class="btIco btIcoDefaultType btIcoMediumSize btIcoDefaultColor btIconCircleShape btFooterLargeTitle"><span data-ico-es="&#xe9fa;" class="btIcoHolder"><span>Categories</span></span></span><div class="btClear btSeparator topSmallSpaced bottomSmallSpaced border"><hr></div><div class="btCustomMenu btFooterCustomMenu"><div class="menu-categories-menu-container"><ul id="menu-categories-menu" class="menu"><li id="menu-item-392440" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392440"><a href="https://floridapolitics.com/archives/category/presidential/">Presidential</a></li><li id="menu-item-409326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-409326"><a href="https://floridapolitics.com/archives/category/coronavirus/">Coronavirus</a><ul class="sub-menu"><li id="menu-item-409328" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-409328"><a href="https://floridapolitics.com/archives/category/coronavirus/">Coronavirus</a></li><li id="menu-item-409325" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-409325"><a href="https://floridapolitics.com/archives/category/corona-economics/">Corona Economics</a></li></ul></li><li id="menu-item-392436" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392436"><a href="https://floridapolitics.com/archives/category/influence/">Legislative</a></li><li id="menu-item-392441" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-392441"><a href="https://floridapolitics.com/archives/category/local/">Communities</a><ul class="sub-menu"><li id="menu-item-392447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392447"><a href="https://floridapolitics.com/archives/category/tallahassee/">Tallahassee</a></li><li id="menu-item-392442" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392442"><a href="https://floridapolitics.com/archives/category/jax/">Jax</a></li><li id="menu-item-392443" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392443"><a href="https://floridapolitics.com/archives/category/orlando/">Orlando</a></li><li id="menu-item-392444" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392444"><a href="https://floridapolitics.com/archives/category/panhandle/">Panhandle</a></li><li id="menu-item-392445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392445"><a href="https://floridapolitics.com/archives/category/south-florida/">South Florida</a></li><li id="menu-item-392446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392446"><a href="https://floridapolitics.com/archives/category/sw-florida/">SW Florida</a></li><li id="menu-item-392448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-392448"><a href="https://floridapolitics.com/archives/category/tampabay/">Tampa Bay</a></li></ul></li><li id="menu-item-392435" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392435"><a href="https://floridapolitics.com/archives/category/federal/">Federal</a></li><li id="menu-item-392430" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392430"><a href="https://floridapolitics.com/archives/category/2022/">2022</a></li><li id="menu-item-392434" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-392434"><a href="https://floridapolitics.com/archives/category/emails-opinions/">Emails &amp; Opinions</a></li>
</ul></div></div><div class="btClear btSeparator topMediumSpaced noBorder"><hr></div></div></div></div></div></div></div></div></section><section id="bt_section60a550500f0fa" class="boldSection topSmallSpaced bottomSmallSpaced btDarkSkin gutter boxed inherit btFooterBelow" style="background-color:#0c0c0c  !important;"><div class="port"><div class="boldCell"><div class="boldCellInner"><div class="boldRow hidden-sm hidden-xs hidden-ms"><div class="boldRowInner"><div class="rowItem col-md-12 col-ms-12  btTextLeft inherit" data-width="12"><div class="rowItemContent"><div class="btClear btSeparator topSmallSpaced noBorder"><hr></div><div class="btText"><p><strong>© Copyright by Extensive-Enterprises 2021. All rights reserved.</strong></p>
</div><div class="btClear btSeparator topSmallSpaced noBorder"><hr></div></div></div></div></div></div></div></div></section><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-430647" class="share-facebook sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-430647" class="share-twitter sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://floridapolitics.com/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div></div><footer>
</footer>
</div>
<div style="display:none">
<div class="grofile-hash-map-2945b27f17d04489a276f48156ade98f">
</div>
</div>
<input type="hidden" id="njt_nofi_checkDisplayReview" name="njt_nofi_checkDisplayReview" value='{"is_home":false,"is_page":false,"is_single":true,"id_page":430647}'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/floridapolitics.com\/archives\/430647-mike-fasano-office-seeks-luggage-for-foster-kids\/":430647};
	</script>
<div id="sharing_email" style="display: none;">
<form action="/archives/430647-mike-fasano-office-seeks-luggage-for-foster-kids/" method="post">
<label for="target_email">Send to Email Address</label>
<input type="email" name="target_email" id="target_email" value="" />
<label for="source_name">Your Name</label>
<input type="text" name="source_name" id="source_name" value="" />
<label for="source_email">Your Email Address</label>
<input type="email" name="source_email" id="source_email" value="" />
<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img style="float: right; display: none" class="loading" src="https://floridapolitics.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input type="submit" value="Send Email" class="sharing_send" />
<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>
<div class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses! </div>
<div class="errors errors-2" style="display: none;">
Email check failed, please try again </div>
<div class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email. </div>
</form>
</div>
<script type='text/javascript' src='https://floridapolitics.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://floridapolitics.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
</script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/floridapolitics.com\/wp-json\/","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.4.1' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202120' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.7' id='wpgroho-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/slick.min.js?ver=5.7.2' id='slick-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/jquery.magnific-popup.min.js?ver=5.7.2' id='jquery-magnific-popup-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/iscroll.js?ver=5.7.2' id='iscroll-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/fancySelect.js?ver=5.7.2' id='fancySelect-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/script.js?ver=5.7.2' id='bold-news-script-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/misc.js?ver=5.7.2' id='bold-news-misc-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/dir.hover.js?ver=5.7.2' id='bold-news-dir-hover-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/sliders.js?ver=5.7.2' id='bold-news-sliders-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/themes/bold-news/framework/js/bt_parallax.js?ver=5.7.2' id='bold-news-bt-parallax-js'></script>
<script type='text/javascript' src='https://floridapolitics.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://floridapolitics.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.7' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202120.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.7',blog:'189632214',post:'430647',tz:'-4',srv:'floridapolitics.com'} ]);
	_stq.push([ 'clickTrackerInit', '189632214', '430647' ]);
</script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'651f2fbc9f78c18e',m:'655182cc69b77a11fd19143e064027bf50259ad4-1621446824-1800-AX++FWsfq7vY6vT5fVikk/SLqR4EoTSQVA9EQeV5gdR0zjo5hQ6IGKBH7BHIbtRfdVYztBNwZp0U/oyuZu3oB4EKuAnsA1h25mbIzUZjAHrtlihaTpxdcWxkSeqDeJC2mmNMprcfA0UDKMHgSSq42trajT+MIrGKYUXYL8QBm5b3SmsVoEDkN8xR099GBeHnmmh+19RA6vxIs666M3c7ELk=',s:[0x720eb0c7e1,0x9d9e345336],}})();</script></body>
</html>
